赞助商广告,谨慎操作

通达信辩证分析指标公式

[复制链接]
查看17 | 回复0 | 2021-1-12 10:00:11 | 显示全部楼层 |阅读模式
公众号
http://www.gaoshouluntan.com/202101/54215.html
</div>
NN:=5;
NN2:=2;
38.2,DOTLINE,COLORBLUE;
61.8,DOTLINE,COLORBLUE;
23.6,DOTLINE,COLORBLUE;
14.4,DOTLINE,COLORBLUE;
XA_1:=C&gt;0;
XA_2:=IF(KDJ.J&lt;(-10),10,0);
XA_3:=CROSS(9.9,XA_2);
XA_4:=(2*CLOSE+HIGH+LOW)/4;
XA_5:=LLV(LOW,NN);
XA_6:=HHV(HIGH,NN);
XA_7:EMA((XA_4-XA_5)/(XA_6-XA_5)*100,5),NODRAW;
XA_8:=MA(XA_7,NN2);
XA_9:MA(XA_7,NN2),NODRAW;
STICKLINE(IF(XA_1,XA_7&gt;XA_9,DRAWNULL),XA_7+3,XA_9,2,1),COLORRED;
STICKLINE(IF(XA_1,XA_7&lt;=XA_9,DRAWNULL),XA_7-3,XA_9,2,0),COLORCYAN;
STICKLINE(IF(XA_1,CROSS(9.9,XA_2),DRAWNULL),XA_7+4,XA_9-5,2,0),COLORBLUE;
STICKLINE(IF(XA_1,CROSS(XA_2,9.9),DRAWNULL),XA_7+4,XA_9-5,2,0),COLORYELLOW;
风险:IF(XA_1,80,DRAWNULL),DOTLINE,COLORMAGENTA;
安全:IF(XA_1,20,DRAWNULL),DOTLINE,COLORGREEN;
XA_10:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
XA_11:=SMA(XA_10,3,1);
XA_12:=SMA(XA_11,3,1);
XA_13:=3*XA_11-2*XA_12;
XA_14:=XA_13&lt;15 AND XA_13&gt;REF(XA_13,1);
XA_15:=XA_13&gt;95 AND XA_13&lt;REF(XA_13,1);
XA_16:=CROSS(XA_7,XA_9) AND XA_9&lt;20 AND XA_7&lt;20;
XA_17:=CROSS(XA_9,XA_7) AND XA_9&gt;80 AND XA_7&gt;80;
JNBUY:IF(XA_16 AND XA_1,20,0),COLORMAGENTA,LINETHICK2;
DRAWICON(JNBUY=20,20,34);
IF(XA_17 AND XA_1,80,100),COLORGREEN,LINETHICK2;
风险区:IF(XA_1,100,DRAWNULL),COLORMAGENTA;
安全区:IF(XA_1,0,DRAWNULL),COLORGREEN;
50,DOTLINE,COLORWHITE;
A00:=XA_7&lt;=XA_9;
A01:=CROSS(30,XA_7);
A02:=BARSLAST(A01=1);
A03:=XA_7&lt;=LLV(XA_7,3) AND A00=1;
A04:=REF(A03,1) AND A00=0;
A05:=CROSS(A04,0.01);
XW1:=BARSLAST(A05=1);
XW2:=REF(XW1,XW1+1)+XW1+1,NODRAW;
A06:=EXIST(A00=1,XW2);
A07:=REF(A06,1)=1 AND A05=1;
A08:=REF(MAX(C,O),XW2);
A09:=REF(MAX(C,O),XW1);
A10:=A09&lt;=A08;
A11:=REF(XA_7,XW2);
A12:=REF(XA_7,XW1);
A13:=A12&gt;=A11;
A14:A13=1 AND A10=1 AND A07=1,NODRAW;
DRAWTEXT(A14=1,50,'*'),COLORLIRED;
DRAWTEXT(A14=1,40,'*'),COLORMAGENTA;
DRAWTEXT(A14=1,60,'*'),COLORYELLOW;
STICKLINE(A14=1,30,70,0,-1),COLORGRAY;


                       
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 马上注册

本版积分规则