赞助商广告,谨慎操作

通达信浩通道主图指标公式

[复制链接]
查看22 | 回复0 | 2021-1-11 10:00:10 | 显示全部楼层 |阅读模式
公众号
http://www.gaoshouluntan.com/202101/54190.html
http://www.gaoshouluntan.com/202101/54191.html
</div>
EXPMA7:EXPMA(C,7),COLORWHITE  LINETHICK1;
EXPMA14:EXPMA(C,14),COLORMAGENTA  LINETHICK1;
EXPMA25:EXPMA(C,25),COLORGREEN  LINETHICK1;
EXPMA43:EXPMA(C,43),COLORGREEN  LINETHICK1;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上轨1+7/100)*DD,DOTLINE,COLORGREEN;
下轨1-7/100)*DD,DOTLINE,COLORGREEN;
中轨上轨+下轨)/2,DOTLINE,COLORGREEN;
疯狂1+14/100)*DD,DOTLINE,COLORGRAY;
抄底1-14/100)*DD,DOTLINE,COLORGRAY;
DRAWNUMBER(ISLASTBAR,上轨,上轨),COLOR00FFFF;
DRAWNUMBER(ISLASTBAR,下轨,下轨),COLORFFFF00;
DRAWNUMBER(ISLASTBAR,中轨,中轨),COLOR00FF00;
DRAWNUMBER(ISLASTBAR,疯狂,疯狂),COLOR0000FF;
DRAWNUMBER(ISLASTBAR,抄底,抄底),COLORWHITE;
上轨绿:IF(上轨&gt;=REF(上轨,1),上轨,DRAWNULL),DOTLINE,COLORGREEN,LINETHICK1;
上轨红:IF(上轨&gt;=REF(上轨,1),上轨,DRAWNULL),DOTLINE COLORRED,LINETHICK1;
中轨绿:IF(中轨&gt;=REF(中轨,1), 中轨,DRAWNULL),DOTLINE,COLORGREEN,LINETHICK1;
中轨红:IF(中轨&gt;=REF(中轨,1), 中轨,DRAWNULL),DOTLINE COLORRED, LINETHICK1;
下轨绿:IF(下轨&gt;=REF(下轨,1), 下轨,DRAWNULL),DOTLINE,COLORGREEN,LINETHICK1;
下轨红:IF(下轨&gt;=REF(下轨,1), 下轨,DRAWNULL),DOTLINE COLORRED,LINETHICK1;
{涨停标注}
STICKLINE(C/REF(C,1)&gt;1.095,C,O,2,0),COLORYELLOW;
STICKLINE(HIGH&lt;REF(LOW,0),HIGH,REF(LOW,0),10,0);
STICKLINE(LOW&gt;REF(HIGH,0) ,LOW,REF(HIGH,0),10,0);
STICKLINE(C=O,H,L,0,0);
STICKLINE((C=O)AND(C&gt;REF(C,0)),C,O,8,0);
STICKLINE((C=O)AND(C&lt;REF(C,0)),C,O,8,0);
{浩瀚三宝}
N:=9;
N1:=6;
M:=14;
TYP := (HIGH + LOW + CLOSE)/3;
BCC1:=(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M)),COLORFF00FF;
CB1:=SMA(BCC1,3,1);
CB2:=SMA(CB1,3,1);
CB3:=3*CB1-2*CB2;
CBB1:=EMA(CB3,5);
CBB2:=REF(CBB1,1);
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI:=(RSI1-50)*5,LINETHICK2,COLORFFFFFF;
R1:=SMA(RSI,3,1);
BD1:=SMA(R1,3,1);
BJ1:=3*R1-2*BD1;
RR1:=EMA(BJ1,5);
RR2:=REF(RR1,1);
RR:=RR1&gt;RR2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
BK1:=(K-50)*5,COLOR00FF00;
KB2:=SMA(BK1,3,1);
DB2:=SMA(KB2,3,1);
JB2:=3*KB2-2*DB2;
BBB1:=EMA(JB2,5);
BBB2:=REF(BBB1,1);
绿钻:RR AND NOT(REF(RR,1)) AND (RR1&lt;-100 AND BBB1&lt;-100) AND CBB1&lt;-100,COLORGREEN,NODRAW;
DRAWICON(绿钻,L-0.5,27);
{好底}
D:=EMA((C*3+H+L+O)/6,5);
A线:=HHV(D,13)COLORYELLOW,LINETHICK2;
B线:=LLV(D,13)COLORYELLOW,LINETHICK2;日平:=&quot;MACD.MACD#DAY&quot;(12,26,9);
周平:=&quot;MACD.MACD#WEEK&quot;(12,26,9);
JC:=(A线-B线);
壹:=COUNT(JC&gt;REF(JC,1)AND A线&gt;REF(A线,1),5)=1 AND JC&gt;REF(JC,1)AND A线&gt;REF(A线,1)AND D&gt;=REF(D,1);
G1:=FILTER(壹=1,10);
G2:=BARSLAST(G1&gt;0);
G3:=IFF(G2&gt;0 AND G2&lt;=10,1,0)=1 AND ((C-REF(C,G2))/REF(C,G2))*100&gt;=5;
概壹:=(SUM(FILTER(G3,10),0)/SUM(G1&gt;0,0))*100;
加1:=COUNT(日平&gt;=0 AND 周平&gt;=0,5)=1 AND 日平&gt;=0 AND 周平&gt;=0;
加2:=FILTER(D=A线 AND REF(D,1)&lt;REF(A线,1)AND REF(D,2)&lt;REF(A线,2),10);
①:=FILTER(加1=1,10);
②:=BARSLAST(①&gt;0);
③:=IFF(②&gt;0 AND ②&lt;=10,1,0)=1 AND ((C-REF(C,②))/REF(C,②))*100&gt;=5;
概加1:=(SUM(FILTER(③,10),0)/SUM(①&gt;0,0))*100;
好底:FILTER(COUNT(D=B线,3)&gt;=2 AND D&gt;B线,5),COLORRED,NODRAW;
DRAWTEXT(好底,L-0.5,'好底'),COLORRED;


                       
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 马上注册

本版积分规则